Table of Contents

DOWNLOAD

stmview.tar.gz

  • stmview-scale.tar.gz - This fork version enable manual selection of minimum offset and scaling for rubbersheed. See the picture 4. This would enable to set better positioning and roughness of the surface map in case when the default (automatic) positioning is not appropriate. Sometimes (if data in STM map has high values >1, the positioning of surface could be far from geometry)

Instalation

  • Correct instalation of OpenDX is expected (tested on SuSE 11.1)
  • Extract STMview folder and try to open MapAndBas-9.net in OpenDX → Data Explorer → Run Visual Program. I would not probably work correctly yet.
  • The “visual program” has hardwired absolute path to *.general files ( /home/prokop/Desktop/STMview ), you need to edit it. Look on the biggest “Control Panel” (see picture 1) and choose correct location of files “upravene-STM-out.genral” and “upravene-BAS.genral” in “Import name” dialog. Alternatively you can edit this dirrectly in text editor in MapAndBas-9.neb and MapAndBas-9.cfg
  • Open “upravene-STM-out.genral” and “upravene-BAS.genral” in text editor and check if the first two lines matches the true location and size of files, if not edit it. Especially if there is relative address, change to absolute adress could help. Alternatively you can create correct new *.general files using “OpenDX → Data Explorer → Import Data → Grid or Scattered file”
 
file = /home/prokop/Desktop/STMview/answer.bas
points = 250
 
file = ./empty05.out
grid = 25 x 25

Usage

  • Anytime you want to open a new file, you should edit the first two lines of “upravene-STM-out.genral” and “upravene-BAS.genral” as described above.
  • After that just Run the visual program MapAndBas-9.net and it should s view the geometry, surface and colorbar immediately. If not, there is probably a mistake in definitiion of paths. In this case try to checke Error message window and/or look on the imege window and run “Windows → Open Visual Program Editor”, there you can check what is wrong (shown yellow)
  • If everythig goes well, check the “Control panel”. There are several smaller controlpanels but the only importaint is the one shown on picture 1. Use picture 1 as a reference guide to this dialogs.
  • To change the view go to Options → View Control, There you want probably set “Mode:” to “Rotate” and/or “Set view” to “Front”

Picture 1 - main Control Panel with help notes

Picture 1 - main Control Panel with help notes

Picture 2 - 3D view with hi opacity (0.9)

Picture 2 - 3D view with hi opacity (0.9)

Picture 3 - View from front (go to " Options -> View Control -> Set View -> Front ") with hi opacity (0.5)

 Picture 3 - View from front (go to " Options -> View Control -> Set View -> Front ") with hi opacity (0.5)

Picture 4 - Example of usage STMview-scale fork

 Picture 4 - Example of usage STMview-scale fork

 
stmview.txt · Last modified: 2011/02/18 13:13 (external edit)
 
Except where otherwise noted, content on this wiki is licensed under the following license:CC Attribution-Noncommercial-Share Alike 3.0 Unported
Recent changes RSS feed Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki